Pubblicato il 09/05/11e aggiornato il

Come visualizzare i menù a tendina quando sono coperti da un video di Youtube.

Se nel vostro blog avete un menù a tendina che si apre verticalmente e siete soliti inserire dei video nella parte alta dei post, vi capiterà senz'altro che alcune voci del menù rimangano nascoste sotto al video

voci del menù nascoste dal video

Per ovviare a questo fastidioso inconveniente si deve necessariamente acquisire il vecchio codice di Youtube e non quello nuovo basato sull'iFrame. In teoria si potrebbe far diventare trasparente l'iFrame mediante l'attributo allowtransparency="true" e modificare il CSS di body { aggiungendo background:transparent; o background-color:transparent; ma ho verificato che il metodo non funziona. Se qualcuno più bravo di me riesce a trovare un sistema alternativo con il nuovo codice sarei molto lieto che me lo indicasse nei commenti.

Dobbiamo quindi inserire il video che copre il menù con il vecchio codice di Youtube. Per far questo bisogna andare su Condividi e mettere la spunta a Utilizza vecchio codice di incorporamento

vecchio codice di youtube

Dobbiamo inserire delle aggiunte per rendere il video trasparente

video trasparente youtube

Si tratta di incollare i due tag evidenziati di giallo nella posizione indicata. Le due stringhe sono

<param name="wmode" value="transparent" /> subito dopo </param> e

wmode="transparent" prima del tag di chiusura ></embed>

Procedere all'inserimento del video di Youtube andando in modalità HTML e incollando il codice. Dopo queste modifiche, il menù si sovrapporrà al video e saranno correttamente visibili tutte le sue voci

menù sovrapposto a video youtube

come può essere verificato in questo post di demo sul Menù Chrome.





6 commenti :

  1. scusa la mia perenne curiosità :) questo problema riguarda anche i video inseriti proprio su blogger.se inserisco i video su blogger il codice è diverso,quindi non è applicabile questa soluzione :(
    oddio è un problema da poco riguarda solo un misero video che ho caricaro.

    RispondiElimina
  2. Ciao ernesto,ho inserito qualche video da megavidoe,come è possibile risolvere il problema con i video di megavideo?il ocidce è diverso da quello vecchio di youtube,è più simile a quello nuovo.c'è un modo per applicare questo metodo ai video di megavideo?

    RispondiElimina
  3. @Tutti ...
    Prova a vedere se il tag
    <param name="wmode" value="transparent" />
    è supportato anche dall'iFRame

    RispondiElimina

Non inserire link cliccabili altrimenti il commento verrà eliminato. Metti la spunta a Inviami notifiche per essere avvertito via email di nuovi commenti. Se ti ho aiutato con il post o con le risposte ai commenti condividi su Facebook o su Twitter. Grazie.